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Presentation Description
This step-by-step presentation will cover both basic and 
advanced Pivot Table features to teach you how to 
generate reports in seconds.  If you are not using Pivot 
Tables to accomplish routine analysis and reporting in 
Excel, then you are missing out on a dynamic and time-
saving tool.   Excel 2007 includes additional Pivot Table 
features not available in Excel 2003.  These feature 
updates will be covered in this presentation.
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Objectives and Highlights
Create Pivot Table reports of subsets of data from a list 
within Excel or from an external data source; 

Use subtotals of criteria based sums, counts, averages and 
create a calculated field;

Format and copy Pivot Table results to another sheet; 

Use time-saving Excel commands to create multiple Pivot 
Tables for separate accounts or categories in seconds; 

Use important new Pivot Table features in Excel 2007 for 
multiple selection of categories, controlled recalculation. and 
the table range name.
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Uses of Pivot Tables
Business intelligence gathering

Quick data analysis

Transform data into meaningful analysis

Discover patterns and exceptions

Populate worksheet cells with formula links

Maintain updates from external data sources
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Live Demonstration
Compare Sales Results over time by categories

Generate separate reports by cost center

Group transaction dates into date ranges, months,
quarters or years 

Sort results within the pivot table

Select rankings and top percentages

Add a custom calculation

Add a calculated field

Connect to and update from an external data source
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Follow up to Presentation

To learn more about the topics discussed in this presentation, visit the following links:

Excel Sample Data Files: PivotTable Reports
http://www.microsoft.com/downloads/thankyou.aspx?familyId=

5e720455-fd3f-47bb-96bf-94819aa214c4&displayLang=en

Demo: Make sense of your data using PivotTable reports
http://office.microsoft.com/training/training.aspx?AssetID=RC102058721033

Excel 2007 Courses at MS Office Online
http://office.microsoft.com/en-us/training/CR100479681033.aspx

Review the Handout examples



   
 

 
 
 
 
 
 
 
Presenter: Judy Borsher, CPA, MBA, CITP, MS Certified Instructor (Office 2007) 
SCG Training & Consulting Corporation 
  
If you are not yet using Pivot Tables as part of your day-to-day data analysis work in Excel, then 
you are missing out on a dynamic and time-saving tool. 
 
This step-by-step presentation will teach you how to generate reports that summarize and 
analyze your data in seconds and demonstrate a variety of uses for Pivot Tables.  Excel 2007 
includes additional Pivot Table features not available in Excel 2003.  The feature updates will be 
covered in this presentation. 
 

 Create a Pivot Table report of unique values, codes or categories from data;  

 Create a Pivot Table report of subsets of data from a large list with sorting 

   and filtering;  

 Create a Pivot Table report of subtotals, counts, averages and other calculations 

based on a list of data;  

 Create a calculated field in a Pivot Table; 

 Format a Pivot Table; 

 Copy Pivot Table results to another sheet; 

 Create a Pivot Table from an external data source vs. an Excel list; 

 Dynamically use Excel commands to create multiple Pivot Tables for separate  

   accounts or categories; 

 Use Pivot Table options for automatic recalculation; 

 Use new features in Excel 2007; 

 Understand considerations regarding exchanging files between Excel 2007 and 2003.   

 

MS Excel 2007  
Tapping into the Power of Pivot Tables 



   
 

 
 

 
 
 
 

Follow Up Links 
 
To learn more about the topics discussed in this presentation, visit the 
following links. 
 
 
Sign-up for Office Newsletters 
http://office.microsoft.com/en-us/help/HA101864261033.aspx?nd_loc=us 
 
 
 
Demo: Make sense of your data using PivotTable reports 
http://office.microsoft.com/training/training.aspx?AssetID=RC102058721033 
 
 
 
Demo: Filter data using PivotTable reports 
http://office.microsoft.com/training/training.aspx?AssetID=RC102080371033 
 
 
 
Demo: Calculate data in PivotTable reports 
http://office.microsoft.com/training/training.aspx?AssetID=RC102102791033 
 
 
 
Excel 2007 Courses at MS Office Online 
http://office.microsoft.com/en-us/training/CR100479681033.aspx 
 
 
 
Excel Sample Data Files: PivotTable Reports 
http://www.microsoft.com/downloads/thankyou.aspx?familyId=5e720455-fd3f-47bb-96bf-
94819aa214c4&displayLang=en 
 



   
 

Examples of Pivot Table uses 
 
The following examples will help you learn how to apply pivot tables to your 
specific sets of data.  These examples correspond to the sample data files found 
at the link on the previous page.  
 

1) Compare your salespeople 

Start with source data that contains information about your salespeople. Here are some of the 
source data records used for the reports in this section.  
 

 

 
Create a pivot table to answer the following questions: 
 

1. What are the order amounts for each salesperson? 
Hint - Drag the Salesperson field into the Row box, and then drag the Order 
Amount field into the Values box (Data area). 
 

2. What are the order amounts for salespeople in a specific country? 
Hint - Drag the Country field into the Report Filter (Page area). You can then 
switch between "pages" to view the data for each country. 
 

3. How are salespeople ranked by order amounts? 
Hint - To sort the salespeople, click the drop-down list on the Salesperson field, 
click More Sort Options, and then Descending. Click the Descending drop-down 
list, and then click Sum of Order Amount.  Click OK. 



   
 

 
 

4. Who are the top five salespeople? 
Hint - To view the top items in a field, click the drop-down list on the Salesperson 
field, click Value Filters, and then click Top 10. Click Top 5 Items by Sum of 
Order Amount across the boxes. 
 

5. How did salespeople perform in a specific quarter? 
Hint  - Drag the Order Date field into the Row box above the Salesperson field. 
Note that the source data contains actual order dates, but it would be nice to group 
the dates by quarter. To do this, click one of the dates, and then click Group 
Selection on the Options tab on the Ribbon. In the By box, click Quarters to select 
it. Click any other selection to deselect it.   
 

6. How does each salesperson's performance vary by quarter? 
Hint - Drag the Sales person field above the Order Date field.  
 

7. What are the details for a specific order amount? 
Hint - Double-click a cell in the PivotTable report to see the data "behind" it. 
 

8. What percent is a specific order of the total order amounts? 
Hint - In this case, you'll create a new data field and use a custom calculation. 
That way, you can compare the original data field (Summary) and the new 
calculated data field (Percent of Total). First, drag the Order Amount field into the 
Values box (Data area) so it appears twice. Double-click the new Order Amount 
field in the Pivot Table, click Show values as, under Normal click % of column 
and change the custom name to Percent of Order Total. 
 

9. What bonus amount should each salesperson receive? 
Hint - All salespeople receive a 10% bonus, but you'd like to award a 15% bonus 
if they exceed $20,000 in orders per quarter. To create a formula that uses 
PivotTable data, you can use a calculated field. Click the report, click Formulas 
on the Options tab on the Ribbon, and then click Calculated Field. In the Name 
box, type Bonus Amount. In the Formula box , enter the formula you want. If you 
want to use data from an existing field in your formula, click the field in the 
Fields box, and then click Insert Field. 
 
This example uses the following formula for the calculated field named  
Bonus Amount. 
=IF(‘Order Amount’>20000,.15*’Order Amount’,.1*’Order Amount’) 

 

  



   
 

2) Compare your products 

Start with source data that contains information about your products. Here are some of the source 
data records used for the reports in this section.  

 

Create a pivot table to answer the following questions: 
 

1. What are the sales totals for each category of product?  
Hint - Drag the Category field into the Row box, and then drag the Sales field into 
the Values box (Data area). 
 

2. What are the sales totals for each product? 
Hint - Drag the Product field into the Row box. 
 

3. What are the three best-selling products in each category?  
Hint - To view the top items in a field, click the drop-down list of the Product 
field, click Value Filters, and then click Top 10.  Under Top 10 Show, select Top, 
3, Items, Sum of Sales. Click OK. 
 

4. What are the quarterly sales by product?  
Hint - Drag the Quarter field into the Column box. 
 

5. How do the sales in the first quarter compare with those in the second?  
Hint - To focus on two quarters only, click the dropdown arrow in the Quarter 
field. Select the check boxes for just the first two quarters. 
 

6. What are the average, largest, and smallest Beverage sales subtotals?  
Hint - You can use more than one summary function for subtotals. Right-click an 
item in the Sales Category field, click Field Settings, and then click one or more 
options under Subtotals. 

7. What is the average sale and minimum sale?  
Hint - In this case, you'll create two new data fields, and then change the summary 
function for each data field. First, drag the Sales field into the Values box (Data 
area) a second time, and then drag it a third time. Right-click a calculation in the 
second data field, and then click Average under Summarize by. Right-click a 
calculation in the third data field, and then click Min under Summarize by. 



   
 

3) Compare your orders 

 

Create a pivot table to answer the following questions: 

1. How do you view an individual order? 
Hint - Drag the Product, Unit Price, Quantity, and Discount fields into the Row 
box. Drag the Extended Price field into the Values box (Data area). Then drag the 
OrderID field into the Report Filter (Page area). You can then switch between 
"pages" to view the data for each order. 

2. How many units of each product were sold? 
Hint - Drag the Product field into the Row box, and then drag the Quantity field 
into the Values box (Data area). 

3. What's the average unit price of each product? 
Hint - Drag the Product field into the Row box, and then drag the Unit Price field 
into the Values box (Data area). Now you can change the summary function for 
the Unit Price data field from Sum to Average. Right-click a calculation in the 
Unit Price field, Select Value Field Settings, and then click Average under 
Summarize by. 

4. What are the ten most expensive products? 
Hint - First, you need to change the summary function for the Unit Price data field 
to Maximum. Right-click a calculation in the Unit Price field, and then click Max 
under Summarize by. Next, display the top ten items in the Product field. Right-
click the Product field, click Filter, Top 10. Under Show, enter Top, 10, Items, 
Max of Unit Price. Click OK. 

 



   
 

4) Compare your customers 

Start with source data that contains information about your customers. Here are some of the 
source data records used for the reports in this section. 

 

 
Create a pivot table to answer the following questions: 
 

1. What products do your customers purchase, and in which quarter?  
Hint - Drag the Customer and Product fields into the Row box. Then drag the Qtr 
1, Qtr 2, Qtr 3, and Qtr 4 fields into the Values box (Data area). 
 

2. What were the top two products purchased by each customer in the third quarter?  
Hint – Right-click the Product field, click Filter, Top 10.  Under Show, enter Top, 
2, Items, Sum of Qtr 3.  Click OK. 
 

3. Who was your top customer in the first quarter?  
Hint – Right-click the Customer field, click Filter, Top 10. Under Show, enter 
Top, 1, Items, Sum of Qtr 1.  Click OK. 
 

4. Who were the top two customers for each product?  
Hint - Drag the Product field to the left of the Customer field. Right-click the 
Customer field, click Filter, Top 10.  Under Show, enter Top, 2, Items, Sum of 
Qtr 4.  Click OK. 

 
 
 



   
 

 
 
PivotTable I: Get started with PivotTable reports in Excel 2007 
 
Prepare the source data 
Here are recommendations for setting up your Microsoft® Office Excel® 2007 worksheet for an Excel 2007 PivotTable® report: 

1. Make sure each column has a heading. These column headings are used to name the fields in the 
PivotTable report (a field summarizes multiple rows of information from the source data).  

2. Put similar data in each column. For example, text items in one column, numbers in another column, 
and dates in another column.  

3. Remove any blank rows or columns.  

Note    If you open in Excel 2007 an Excel workbook created in a version prior to Excel 2007, and you create 
an Excel 2007 PivotTable report, the layout area will be in Classic PivotTable layout instead of in the Excel 
2007 layout. To avoid this, follow these steps:  

1. Save the data as an Excel 2007 file.  

2. Close the workbook.  

3. Open it again.  

4. Create the PivotTable report.  

If you do this before you create the PivotTable report, the layout area will be in Excel 2007 layout. 

 
Create a PivotTable report 
1. Select a cell or range of cells.  

2. Click the Insert tab. In the Tables group, click the arrow on PivotTable, and on the menu, click 
PivotTable.  

The Create PivotTable dialog box opens. 

3. Select a table or range is already selected for you. The Table/Range box shows the range of the 
selected data.  

4. New Worksheet is also selected for you as the place where the report will be placed (you can click 
Existing Worksheet if you don't want the report placed in a new worksheet). Click OK.  

On the left is the layout area ready for the PivotTable report, and on the right is the PivotTable Field 
List. This list shows the column titles from the source data: Each title is a field in the list. 
 
 



   
 

5. In the field list, select the check boxes next to the fields that you want to add to the report.  

Fields are automatically added to the report. Fields that are non-numeric are added to the Row Labels 
area of the report. As you add more non-numeric fields, Excel places them on the inside of fields 
already on the PivotTable report, building a hierarchy. Numeric fields are added on the right. 

o  To remove a field from the report, clear the check box next to the field name in the field list.  

o  To remove all the fields from a report so that you can start over again, click the Options tab on the 
Ribbon under PivotTable Tools. In the Actions group, click the arrow on the Clear button, and 
then select Clear All.  

o  To delete the entire report, click the Options tab. In the Actions group, click the arrow on Select. 
Click Entire Table. Then press DELETE.  

 
Sort a field 
Right-click a cell in the field you want to sort. Point to Sort, and then click an option. For example, click Sort 
Largest to Smallest or More Sort Options.  

 
Group a field 
You can group data that contains dates or times by following these steps.  

1. Right-click a cell in the field you want to group, and then click Group. In the Grouping dialog box, 
select an option, and then click OK.  

2. To ungroup, click in the grouped field, right-click, and then select Ungroup.  

 
Add a report filter 
Use a report filter to focus on a subset of data in the report, often a product line, a time span, or a geographic 
region. 

In the PivotTable Field List, right-click a field name, and then select Add to Report Filter.  

 
Pivot a report 
When you pivot a PivotTable report, you transpose the vertical or horizontal view of a field, moving rows to the 
column area or moving columns to the row area. 

Right-click the field you want to pivot. Point to Move, and then select Move "field name" to Columns, or 
select Move "field name" to Rows.  

 
 



   
 

 
Move a PivotTable report to another location 
1. Click the PivotTable report.  

2. Click the Options tab on the Ribbon under PivotTable Tools. In the Actions group, click Move 
PivotTable.  

The Move PivotTable dialog box opens. 

3. Under Choose where you want the PivotTable report to be placed, either select New Worksheet, 
or in the Location box for Existing Worksheet, type the first cell in the range of cells where you want 
to locate the PivotTable report. Then click OK.  

 
Print a PivotTable report 
To set printing options, click in the PivotTable report. Click the Options tab on the Ribbon under PivotTable  
 
Tools. In the PivotTable group, click Options. In the PivotTable Options dialog box, on the Printing tab,  
 
select the options you want. 

 



   
 

PivotTable II: Filter PivotTable report data in Excel 2007 
 
Set a filter for text in Row Labels or Column Labels 
Click the arrow next to Row Labels or Column Labels, depending on whether the field you want to filter is 
in the row or column area of the report. When you click that arrow, a menu appears with the Select field 
box at the top, which you use to select which field to apply a filter to.  

The menu also shows a list of all the rows in whatever field you select. Looking at the items in the list is a 
way to verify that you've selected the correct field to filter. To filter the report: 

Clear the check box next to (Select All) in the list to clear all the check boxes next to the items in the list. 
Then click the check boxes next to the items you want to display in the PivotTable report.  

Or, 

Point to Label Filters and select a comparison operator such as Equals or Contains. In the Label Filter 
<Field Name> dialog box, in the box on the right, type text. Then click OK.  

You can also set a filter by clicking within a field instead of clicking the arrow next to Row Labels or 
Column Labels. 

To hide selected items within a field, select the items, point to Filter, and then select Hide Selected Items.  

To display selected items within a field, select the items, point to Filter, and then select Keep Only 
Selected Items.  

 
Set a value filter 
Click the arrow next to Row Labels or Column Labels. Point to Value Filters, select a comparison 
operator such as Equals, Does Not Equal, or Greater Than. In the Value Filter <Field Name> dialog box, 
type numbers in the last box, and then click OK.  

 
Set a date filter 
Click the arrow next to Row Labels or Columns Labels. You'll know if you are in an area in which you can 
filter by dates if the Date Filters command is available.  

Clear the check box next to (Select All), and then select the check boxes next to the dates you want to 
display. Click OK. Or,  

Click Date Filters, and then select a comparison operator such as Before, After, or Between. In the Date 
Filter <Field Name> dialog box, type dates in the empty boxes. Then click OK.  

 
 



   
 

Remove filters 
You can remove filters one at a time, or you can quickly remove all filters at once.  

 

Remove a filter in the PivotTable report 

To remove a filter from a specific field, click the filter icon wherever the filtered field appears in the report, 
either on Row Labels or on Column Labels. Then click Clear Filter From <Field Name>. Or select the check 
box next to (Select All) to make all data in that field visible. 

To clear a filter on items within a field, right-click within a field, point to Filter, and then click Clear Filter From 
<Field Name>. 

If you do not see the Clear Filter From command for the filtered field: 

Be sure that you have selected the correct area of the report to clear the filter from: either rows or columns.  

Is the correct field name shown in the Select field box? You see that box when you click the filter icon. The 
field name in that box must match the name of the field you want to clear the filter from. If the field name in 
the box is incorrect, select the correct field from the list that appears when you click the arrow next to the 
box.  

 

Remove a filter in the PivotTable Field List 

Move the cursor over the filter icon next to the field name you want to remove the filter from. Click the arrow 
that appears, and then click Clear Filter From <Field Name>. Or select the check box next to (Select All) to 
make all data in the field visible. 

 

Remove all filters at one time 

At the top of the window, on the Ribbon, click the Options tab under PivotTable Tools. In the Actions group, 
click Clear, and then click  
 
Clear Filters. Be sure you really want to do this before you undo all your selections. 

 
 



   
 

PivotTable III: Calculate data in PivotTable reports in Excel 2007 
 
Change summary functions 
Excel automatically adds up numbers using the SUM function. You can change the summary function. 

1. Right-click in the Values field. Point to Summarize Data By, and then click the summary function you 
want to use.  

2. To switch back to SUM, right-click again in the Values field, point to Summarize Data By, and then 
click Sum.  

 
Using custom calculations 
To create a custom calculation, right-click in the Values area, point to Summarize Data By, and click More 
Options. Click the Show values as tab, and then click a function in the Show values as list.  

You can use the following functions in a custom calculation: 

Function Result 

Normal Turns off custom calculation. 

Difference 
From 

Displays values as the difference from the value of the Base item in the Base field. 

% Of Displays values as a percentage of the value of the Base item in the Base field. 

% Difference 
From 

Displays values as the percentage difference from the value of the Base item in the 
Base field. 

Running Total 
in 

Displays the value for successive items in the Base field as a running total. 

% of row Displays the value in each row or category as a percentage of the total for the row or 
category. 

% of column Displays all the values in each column or series as a percentage of the total for the 
column or series. 

% of total Displays values as a percentage of the grand total of all the values or data points in the 
report. 

Index Calculates a value as follows: ((value in cell) x (Grand Total of Grand Totals)) / ((Grand 
Row Total) x (Grand Column Total)). 

Create your own formulas by using Calculated Fields 
1. At the top of the window, on the Ribbon, click the Options tab under PivotTable Tools. In the Tools 

group, click the Formulas button, and then click Calculated Field.  

2. Type a name for the formula in the Name box, and type the formula in the Formula box. Then click 
OK.  

3. To delete a formula, select the name in the Name box, and then click Delete.  

 



   
 

The GETPIVOTDATA function 
The GETPIVOTDATA function works for cells in the Values area. The function is automatically entered when  
 
you type an equal sign outside the PivotTable report and select a single cell inside the Values area of the  
 
report. If you pivot a report, the function will return the data in the referenced cell, even if the cell has changed 
 
location. 

GETPIVOTDATA is on by default, but you can turn it off if you prefer. At the top of the window, on the Ribbon, 
 
click the Options tab under PivotTable Tools. In the PivotTable group, click the arrow on Options, and then 
 
click Generate GetPivotData. 

 


	23a Borsher.pdf
	2008 AICPA Information Technology Conference
	Presentation Description
	Objectives and Highlights
	Uses of Pivot Tables
	Live Demonstration
	Follow up to Presentation

	23b Borsher

